Exchange Server 2013 POP3 Bağlantı Sorunu ve Çözümü

By | 14/11/2015

Merhaba arkadaşlar,

Geçen hafta içinde Exchange 2010’dan Exchange 2013 ortamına geçiş yaptığımız bir projemizde yaşadığımız POP3 servisi problemini nasıl giderdiğimizi paylaşmak istiyorum.

Geçiş yaptığımız ortamda 1 adet Exchange 2010 tüm roller üzeride sorunsuz olarak çalışmakta idi, biz ortama 1 adet Exchange 2013 CAS ve 2 adet Exchange 2013 Mailbox sunucusu kurup konumlandırdık. Tüm Exchange Server 2013 sunucularımız CU9 versiyonunu kullanıyor durumda idi.

Geçiş testleri sırasında POP3 Servisi hem CAS hemde Mailbox sunucular üzerinde start durumda olmasına rağmen Exchange Server 2013 Mailbox sunucusu üzerine taşıdığımız ortama Outlook ile POP3 servisi ile bağlı test kullanıcısının maillerine erişmediğini tespit ettik.

Exchange 2013 CAS sunucusu POP3 portuna erişimi Telnet ile test ettiğimizde servisin karşılama mesajını vermediğini ve 5-10 sn sonra bağlantının koptuğunu tespit ettik.

Konu ile akalı olarak biraz araştırma yaptığımızda aynı sorunu yaşayan bir arkadaşımızın paylaştığı makaleyi buldum sorunu incelediğimizde aynı sorunu yaşadığımız tespit ettim ve burada önerilen yöntemi uyguladığımda POP3 Servisi  artık telnet testinde karşılama mesajını vermeye başladı ve kullanıcmız test kullanımız maillerine POP3 üzerinden erişmeye başladı.

Exchange Server Power Shell üzerinde aşağıdaki komutu Client Acces Server (CAS) adı için çalıştırınız.

Get-ServerComponentstate -Identity CASSERVERADI

Yukarıdaki komut çıktısı aşağıdaki resimdeki gibi gelecektir. Karşınıza gelen bu listede PopProxy Component’inin aşağıdaki resimdeki gibi Inactive durumda olduğunu görürseniz sizin sorununuzuda büyük ihtimalle bu demektir.

EXC2013_POP3_Problem_1

PopProxy Componentini Active duruma getirmemiz gerekiyor POP3 servisinin düzgün bir şekilde çalışabilmesi için.

PopProxy Active duruma getiren Exchange Server 2013 PowerShell komutu aşağıdaki gibidir.

Set-ServerComponentState -Identity CASSERVERADI -Component PopProxy -Requester HealthAPI -State Active

Daha sonra POP3 servisini Telnet ile test ettiğinizde bağlantının aşağıdaki gibi sorunsuz olarak kurulduğunu görebiliyoriseniz Outlook bağlantısı da büyük ihtimalle sorunsuz olarak çalışacaktır eğer ilgili Outlook versiyonunun Exchange 2013’e bağlantı için gerekli olan güncelleştirmeleri yüklü ise.

Telnet Testi:

EXC2013_POP3_Problem_2

Bu sorundan ne öğrendim, bundan sonra kurulum yaptığım ortamlarda herhangi  bir servisin çalışır durumda olduğuna aldanmayacağım, servis’e erişimi test etmeden bu servis çalışıyor dememek lazım.

Faydası olması dileklerimle.

Kaynak:

http://blog.jasonsherry.net/2014/08/19/exchange-2013-pop3-service-drops-connections-fix/

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.